August 2019
SunMonTueWedThuFriSat
    123
45678910
11121314151617
18192021222324
25262728293031

Calendar Calendar

Liện Hệ

 dailongcomputer_printer

Thống Kê
Hiện có 1 người đang truy cập Diễn Đàn, gồm: 0 Thành viên, 0 Thành viên ẩn danh và 1 Khách viếng thăm

Không

[ View the whole list ]


Số người truy cập cùng lúc nhiều nhất là 627 người, vào ngày Sat Dec 11, 2010 9:11 pm
Statistics
Diễn Đàn hiện có 3728 thành viên
Chúng ta cùng chào mừng thành viên mới đăng ký: khongluibuoc882

Tổng số bài viết đã gửi vào diễn đàn là 404 in 379 subjects
Kho Phần Mềm
Tổng hợp các bài lab ccna(st) Logo15
Gallery


Tổng hợp các bài lab ccna(st) Empty

Tổng hợp các bài lab ccna(st)

Go down

Tổng hợp các bài lab ccna(st) Empty Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:44 am

Lab 1-1: Đăng nhập vào router – giao diện dòng lệnh

Yêu cầu

Bài thực hành này giúp người đọc làm quen với chế độ lệnh (CLI-Command Line Interface) và một số lệnh cơ bản của hệ điều hành CiscoIOS.

Hướng dẫn

1. Nối cáp

– Để đảm bảo an toàn thiết bị trong khi thực hành, cần phải tắt hoàn toàn nguồn điện các thiết bị trong khi nối cáp. Dùng cáp Console (cáp Rolled) nối cổng COM1 của máy PC (dùng Terminal chuyển đổi từ DB-9 sang RJ45) với cổng Console của Router.

– Kiểm tra lại dây đảm bảo đã nối chắc chắn.

2. Đăng nhập vào router

Khởi động Windows, vào HyperTerminal
Start - Programs - Accessories - Communications - Hyper Terminal

Tổng hợp các bài lab ccna(st) Wol_errorThis image has been resized. Click this bar to view the full image. The original image is sized 732x92.
Tổng hợp các bài lab ccna(st) 92211800


- Name: <tên file lưu trữ >
- Icon: chọn biểu tượng tuỳ thích.

Tổng hợp các bài lab ccna(st) 93525793

Connect using : COM1

Tổng hợp các bài lab ccna(st) 15727885
Tổng hợp các bài lab ccna(st) Image006


– Thiết lập cấu hình như trong hộp thoại sau:

Tổng hợp các bài lab ccna(st) Image008Tổng hợp các bài lab ccna(st) 10955759

Khởi động Router
– Bật nguồn cho Router.
– Xem các thông tin về Router được hiển thị trên HYPER TERMINAL.

System Bootstrap, Version 11.0(10c), SOFTWARE

Version của IOS đang lưu trong ROM
Copyright (c) 1986-1996 by cisco Systems
2500 processor with 14336 Kbytes of main memory ← Cho biết loại bộ xử lý Router (2500) và
dung lượng bộ nhớ RAM

Notice: NVRAM invalid, possibly due to write erase.

F3: 4+573916 at 0x3000060

Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software – Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-I-L), Version 12.1(3), RELEASE SOFTWARE (fc1)

Version của IOS đang lưu trong flash

Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Thu 06-Jul-00 07:33 by cmong
Image text-base: 0x0303E710, data-base: 0x00001000

cisco 2509 (68030) processor (revision M) with 14336K/2048K bytes of memory.
Processor board ID 07143970, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
8 terminal line(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)

--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: no
Would you like to terminate autoinstall? [yes]:

Press RETURN to get started!

– Nhấn Enter để tiếp tục xuất hiện dấu nhắc đợi lệnh, lúc này đang ở user mode, để vào priviledge mode, dùng lệnh enable

Router>_
Router>enable
Router#

– Để quay lại user mode bằng lệnh disable hoặc lệnh exit

Router#disable
Router>

– Dùng lệnh logout để thoát chế độ dòng lệnh

Router>logout
Router con0 is now available
Press RETURN to get started.

– Bạn đang ở chế độ user mode, nhập ký tự ? (chấm hỏi) để xem các lệnh được dùng trong chế độ này:

Router>?
Exec commands:
access-enable Create a temporary Access-List entry
access-profile Apply user-profile to interface
clear Reset functions
connect Open a terminal connection
disable Turn off privileged commands
disconnect Disconnect an existing network connection
enable Turn on privileged commands
exit Exit from the EXEC
help Description of the interactive help system
lock Lock the terminal
login Log in as a particular user
logout Exit from the EXEC
mrinfo Request neighbor and version information from a multicast
router
mstat Show statistics after multiple multicast traceroutes
mtrace Trace reverse multicast path from destination to source
name-connection Name an existing network connection
pad Open a X.29 PAD connection
ping Send echo messages
ppp Start IETF Point-to-Point Protocol (PPP)
resume Resume an active network connection
--More--

Nếu số hàng thông tin cần hiển thị nhiều hơn một trang màn hình (25 hàng), cuối màn hình hiện chữ --More-- bạn nhấn phím ENTER để xem hàng kế tiếp, hoặc phím SPACE để xem trang kế tiếp. Nếu bạn nhấn phím ENTER, thông tin sẽ hiển thị thêm từng hàng. Nếu bạn dùng SPACE BAR, thông tin sẽ hiển thị theo trang màn hình.
– Lệnh giúp đỡ (?) rất hữu dụng, bạn có thể dùng trong bất kỳ chế độ nào, Router sẽ đưa ra các mục chọn được phép sử dụng và ý nghĩa của lệnh đó. Ví dụ bạn muốn xem tiếp các phần của lệnh show, bạn gõ:

Router>show ?

Hoặc bạn không nhớ tất cả những lệnh bắt đầu bằng các k‎ tự te, bạn có thể gõ:

Router>te?
Telnet Terminal

Khi đó, router sẽ liệt kê tất cả các lệnh bắt đầu bằng te.

– Hệ điều hành trong Router Cisco cho phép gõ tắt. Bạn chỉ cần gõ số ký tự đủ để phân biệt các câu lệnh với nhau là câu lệnh được chấp nhận, hoặc bạn nhấn phím TAB để hiện đầy đủ câu lệnh.

Router>tel[TAB]
Router>telnet

– Vào chế độ global-configuration-mode, dùng lệnh configuration terminal

Router#configuration terminal
Enter configuration commands, one per line. End with CNTL/Z.

– Một số tổ hợp phím tắt: Kỳ thi CCNA đòi hỏi người học phải sử dụng thành thạo tổ hợp các phím tắt này. Ngòai ra, một số chương trình dùng làm terminal có thể không hỗ trợ các tổ hợp phím này.

Ctrl-A

Trở về đầu dòng
Ctrl-B
Mũi tên trái
Trở về một ký tự
Esc-B

Trở về một từ
Ctrl-E

Đến cuối dòng
Ctrl-F
Mũi tên phải
Tới một ký tự
Ctrl-P
Mũi tên lên
Đến câu lệnh đã thực hiện trước đó
Ctrl-N
Mũi tên xuống
Đến câu lệnh đã thực hiện sau câu lệnh đó

3. Xem thông tin về cấu hình của router

Tại chế độ privileged mode, bạn hãy thực hiện các lệnh sau, và kiểm tra kết quả của từng lệnh:

show version
Xem tên files IOS, version của IOS đang sử dụng, cấu hình phần cứng của Router, chế độ BOOT (thanh ghi)
show flash:
dir flash
Xem file IOS đang lưu trong flash
dir nvram
Xem các file đang lưu trong NVRAM
show interface [interface]
Xem cấu hình của tất cả các cổng hay của cổng được chỉ định
show running-config
Xem cấu hình chung đang sử dụng
show startup-config
show configuration
Xem cấu hình chung dùng cho khởi động (lưu trong NVRAM)
show clock
Xem đồng hồ
show user
Xem các kết nối đang truy cập vào Router
show line
Xem tất cả các kết nối (line) của Router
show ip route
Xem bảng chọn đường của Router
show arp
Xem bảng tương ứng (map) từ địa chỉ MAC và địa chỉ IP
show host
Xem tên và địa chỉ của các host đã biết (đã được đặt tên)

– Xoá cấu hình được router dùng lúc khởi động: dùng lệnh erase startup-config. Khi đã thực hiện lệnh này, nếu xem lại cấu hình khởi động, bạn sẽ nhận thông báo lỗi

Router#erase startup-config
Erasing the nvram filesystem will remove all files!
Continue? [confirm]
[OK]
Erase of nvram: complete
Router#sh start
%% Non-volatile configuration memory is not present
Router#
4. Sử dụng HYPER TERMINAL

Sử dụng trình tiệc ích truyền file của HYPER TERMINAL
– Để có thể cấu hình nhanh một Router, bạn có thể soạn thảo trước các câu lệnh bằng NotePad theo đúng trình tự, lưu dưới dạng file text, sau đó dùng Send Text File... (Transfer -> Send Text File...) để truyền File:

Ví dụ: bạn soạn thảo file SHOW.TXT như sau:

show version
show flash:
show running-config
show startup-config
configuration terminal
exit

– Cách truyền file chỉ hữu dụng với các lệnh cấu hình không có các thông số xác nhận (một dòng là câu lệnh hoàn chỉnh), không thực hiện được cho các câu lệnh có thông số lựa chọn. Chẳng hạn: không nên dùng cho lệnh enable (vì có thể phải xác nhận mật khẩu), không thể dùng cho lệnh lưu cấu hình vào NVRAM vì có xác nhận tên file:

Router#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Chỉnh thời gian trễ dòng lệnh
Để có thể theo dõi kịp các thông báo, bạn cài thời gian trễ khi truyền từng dòng khoảng 2000ms - 4000ms (Chọn File – Properties – ASCII Setup ...)
Tổng hợp các bài lab ccna(st) Image015
Capture thao tác
– Trong quá trình làm Lab, bạn muốn ghi lại các thao tác, các thông tin của Router khi thực hành, bạn sử dụng Capture của Hyper -Terminal (Transfer – Capture Text ... )
Tổng hợp các bài lab ccna(st) Image017
– Bạn hãy nhập tên file với đường dẫn đầy đủ. Bắt đầu từ lúc này, tất cả các thao tác của bạn và kết quả đều được ghi lại. Khi thực hiện xong, nhớ Stop Capture (Transfer -> Capture Text -> Stop) để lưu file và sử dụng WordPad để xem lại.
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:44 am

Lab 1-2: Đặt mật khẩu cho router


Tổng hợp các bài lab ccna(st) 1-2%201-3%20Dat%20mat%20khau%20truy%20cap%20%28Cac%20lenh%20co%20ban%29

Mô tả

Thông thường có các loại mật khẩu để bảo mật cho một router Cisco như sau:
– Loại mật khẩu đầu tiên là enable. Lọai này được sử dụng để vào chế độ enabled mode. Router sẽ yêu cầu bạn nhập mật khẩu này vào khi bạn đánh lệnh enable từ user mode để chuyển sang chế độ enable mode.
– Ba loại còn lại là mật khẩu khi người dùng truy cập qua cổng console, cổng Aux, hay Telnet.

¤ Mật khẩu có phân biệt chữ hoa hay chữ thường (case sensitive), và không quá 25 ký tự. Các ký tự này có thể là chữ hoa, chữ thường, con số, các dấu chấm câu và khoảng cách; tuy nhiên ký tự đầu tiên không được là dấu trắng.

Thực hiện

Mật khẩu truy cập vào enable mode
– Hai loại enable mật khẩu trên router, đặt bằng các lệnh sau:

Router(config)#enable secret vip ¬ mật khẩu là vip
Router(config)#enable password cisco ¬ mật khẩu là cisco

– Ở chế độ mặc định, mật khẩu ở dạng không mã hóa (clear-text) trong file cấu hình; Lệnh enable secret password sẽ mã hóa các mật khẩu hiện có của router. Nếu có đặt enable secret, nó sẽ có hiệu lực mạnh hơn các mật khẩu còn lại.

Mật khẩu truy cập vào User Mode

1. Đặt mật khẩu cho user mode bằng lệnh line, xem xét các thông số theo sau bằng cách đánh dấu ? sau lệnh line.

Router(config)#line ?
<0-4> First Line number
aux Auxiliary line
console Primary terminal line
vty Virtual terminal

– aux đặt mật khẩu cho cổng aux, thường dùng khi cấu hình cho modem gắn router, quay số vào để cấu hình router.
– console đặt mật khẩu trước khi vào user mode
– vty đặt mật khẩu để telnet vào router. Nếu không đặt mật khẩu, không thể thực hiện telnet vào router.

Để đặt mật khẩu cho user mode, cần xác định line muốn cấu hình và dùng lệnh login để router đưa ra thông báo chứng thực đòi hỏi nhập mật khẩu.

2.Đặt mật khẩu trên cổng aux của router:

vào global config mode đánh lệnh line aux 0.
Chú ý rằng chỉ được chọn số 0 vì thông thường chỉ có một cổng auxilary trên router.

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#line aux 0
Router(config-line)#login
Router(config-line)#password vip

Câu lệnh login rất quan trọng, nếu không có lệnh này, router sẽ không thông báo đòi hỏi chứng thực.

3. Đặt mật khẩu truy cập cho cổng console trên router: dùng lệnh line console 0

Router(config)#line console 0
Router(config-line)#login
Router(config-line)#password vnpro

4. Đặt mật khẩu telnet: dùng lệnh line vty

Router(config-line)#line vty 0 4
Router(config-line)#login
Router(config-line)#password vnpro

Sau khi router cấu hình địa chỉ IP, bạn có thể dùng chương trình Telnet để cấu hình và kiểm tra router thay vì sử dụng cáp console.
Kiểm tra

Kiểm tra lại các loại mật khẩu đã đặt bằng cách xem cấu hình hiện tại đang chạy, thực hiện lệnh show running-config:

Router#show running-config
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 $1$Y3Hx$iF7j2hPkFe6/hwJG.NZOg.
enable password cisco
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
!
line con 0
password rrr
login
line aux 0
password vip
login
line vty 0 4
password RRR
login
!
end

Trong cấu hình ta thấy enable secret password ở dạng mã hóa. Các mật khẩu khác ở dạng không mã hóa. Hệ điều hành Cisco IOS cho phép mã hóa tất cả các mật khẩu trong file cấu hình bằng lệnh service password-encryption tại global configuration mode:

Router#
Router#conf ter
Router(config)#service password-encryption
Router(config)# [Ctrl–Z]
Router#show running-config
Building configuration...

Current configuration:
!
version 12.0
service password-encryption
!
hostname Router
!
enable secret 5 $1$Y3Hx$iF7j2hPkFe6/hwJG.NZOg.
enable password 7 01100F175804
!
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
no ip address
shutdown
!
!
line con 0
password 7 111B0B17
login
line aux 0
password 7 0312521B
login
line vty 0 4
password 7 1520393E
login
!
end

Tất cả các mật khẩu đã được mã hóa. Mật khẩu Enable secret vẫn ở dạng cũ; Mức độ mã hóa được hiển thị bằng chỉ số đứng ngay trước mỗi mật khẩu. Các giá trị có thể có của chỉ số này là:

– 7 : mật khẩu được mã hóa theo thuật toán hai chiều MD7; mật khẩu dạng này có thể giải mã được.
– 5 : mật khẩu được mã hóa theo thuật toán một chiều MD5; không thể giải mã được dạng này.
– 0 : (hoặc không có giá trị) mật khẩu được hiển thị ở dạng không mã hóa.
Nếu tắt chế độ mã hóa với câu lệnh no service password-encryption, thì mật khẩu vẫn ở dạng mã hóa trừ khi đặt lại mật khẩu.
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:45 am

Lab 1-3: Các lệnh cơ bản của hệ điều hành Cisco IOS

Tổng hợp các bài lab ccna(st) 1-2%201-3%20Dat%20mat%20khau%20truy%20cap%20%28Cac%20lenh%20co%20ban%29

1. Đặt router banner

Đặt lời chào khi người dùng đăng nhập qua cổng console hay telnet vào router. Trong thực tế, lệnh banner được dùng để ra các cảnh báo đối với các truy cập trái phép vào router. Lệnh này chỉ có ‎ tính chất cung cấp thông tin về hệ thống mà người dùng đang truy cập vào.

– Câu lệnh thực hiện tại global configuration mode như sau

Router(config)#banner ?
LINE c banner-text c, where 'c' is a delimiting character
exec Set EXEC process creation banner
incoming Set incoming terminal line banner
login Set login banner
motd Set Message of the Day banner

– Tham số motd thường hay được sử dụng nhất. Thông số này đưa ra thông báo cho mọi người khi quay số hay kết nối với router thông qua Telnet, cổng aux hay cổng console.

Router(config)#banner motd ?
LINE c banner-text c, where 'c' is a delimiting character
Router(config)#banner motd #
Enter TEXT message. End with the character '#'.
Chao cac hoc vien lop CCNA
#
Router(config)#^Z
Router#
%SYS-5-CONFIG_I: Configured from console by console
Router#exit

Router con0 is now available
Press RETURN to get started.

Chao cac hoc vien lop CCNA

Router>

– Để loại bỏ banner dùng lệnh no banner login

Router#
Router#conf t
Router(conf)#no banner login

2. Cấu hình các cổng giao tiếp trên router:

Cấu hình các cổng giao tiếp của router là một trong những tác vụ cấu hình quan trọng nhất trong qui trình cấu hình một thiết bị định tuyến router. Tác vụ này phải chính xác để router có thể trao đổi các thông tin với các thiết bị khác cũng như là có thể trao đổi được dữ liệu. Các bước cấu hình như sau:

– Tại chế độ cấu hình tòan cục, ta dùng lệnh interface [loại interface] [số thứ tự]
– Để cho phép interface hoạt động, hãy dùng lệnh no shutdown.
– Để tắt một interface dùng lệnh shutdown.
– Nếu một interface bị shutdown, trạng thái hiển thị sẽ là administratively down khi dùng lệnh show interface để xem trạng thái của một cổng giao tiếp. Khi đó, nếu dùng lệnh show running-config, ta sẽ thấy kết quả lệnh sẽ hiển thị trạng thái của các giao tiếp là shutdown.
– Mặc định các interface ở trạng thái shutdown.

Router#sh int e0
Ethernet0 is administratively down, line protocol is down
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int e0
Router(config-if)#no shutdown
Router(config-if)#^Z
%LINK-3-UPDOWN: Interface Ethernet0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to up

Router#sh int e0
Ethernet0 is up, line protocol is up

– Đặt địa chỉ IP cho một interface

Router(config)#int e0
Router(config-if)#ip address 172.16.10.2 255.255.255.0
Router(config-if)#no shut

– Nếu muốn đặt thêm một địa chỉ thứ hai cho cổng giao tiếp, phải dùng tham số secondary.
– Một cổng giao tiếp của router có thể đặt nhiều địa chỉ IP.

Router(config-if)#ip address 172.16.20.2 255.255.255.0 secondary
Router(config-if)#^Z

Router#sh run
Building configuration
Current configuration:
...
!
interface Ethernet0
ip address 172.16.20.2 255.255.255.0 secondary
ip address 172.16.10.2 255.255.255.0
!

– Một số lệnh cho cổng serial của router:

Lệnh clock rate: đặt xung clock cho DCE. Nếu đặt lệnh clock rate trên một cổng giao tiếp không phải là DCE thì câu lệnh không có tác dụng.

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0
Router(config-if)#clock rate ?
Speed (bits per second)
1200
2400
4800
9600
19200
38400
56000
64000
72000
125000
148000
250000
500000
800000
1000000
1300000
2000000
4000000
<300-4000000> Choose clockrate from list above
Router(config-if)#clock rate 64000
%Error: This command applies only to DCE interfaces
Router(config-if)#int s1
Router(config-if)#clock rate 64000

Lệnh bandwith: Ở chế độ mặc định, các cổng giao tiếp của thiết bị định tuyến Cisco sẽ họat động ở băng thông của T1 (1,544 Mbps). Tuy nhiên, lệnh bandwidth không ảnh hưởng gì đến tốc độ truyền dữ liệu thật sự của cổng giao tiếp. Lệnh bandwidth chỉ có tác động đến quá trình tính tóan metric của các giao thức định tuyến như IGRP, EIGRP hay OSPF để tính toán chi phí tốt nhất tới một mạng ở xa.

Router(config-if)#bandwidth ?
<1-10000000> Bandwidth in kilobits ← Bandwidth được tính bằng Kbit

Router(config-if)#bandwidth 64

– Mô tả cho cổng giao tiếp: mô tả rất hữu ích cho người quản trị và nó chỉ có tác dụng cục bộ, dùng lệnh description tại interface mode; để xem lại dùng lệnh show run hay show interface

Router(config)#int e0
Router(config-if)#description Sales Lan
Router(config-if)#int s0
Router(config-if)#description Ket noi Wan toi VnPRO

Router#sh run
[...]
!
interface Ethernet0
description Sales Lan
ip address 172.16.10.30 255.255.255.0
!
interface Serial0
description Ket noi Wan toi PTIT
no ip address
no ip directed-broadcast
no ip mroute-cache

Router#sh int e0
Ethernet0 is up, line protocol is up
Hardware is Lance, address is 0010.7be8.25db (bia 0010.7be8.25db)
Description: Sales Lan
...

Router#sh int s0
Serial0 is up, line protocol is up
Hardware is HD64570
Description: Ket noi Wan toi PTIT
...
Router#

3. Đặt hostname
Đặt tên cho router bằng lệnh hostname, tên chỉ có tác dụng cục bộ. Việc đặt hostname là cần thiết trong qui trình cấu hình router.

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname RRR
RRR(config)#

4. Lưu cấu hình
Dùng lệnh copy running-config startup-config hay write memory để lưu file cấu hình từ DRAM vào NVRAM (có thể dùng lệnh tắt copy run start hay wr)

RRR#copy run start
Destination filename [startup-config]?[Enter]
Building configuration...

Xem lại file đã lưu trong NVRAM

RRR#show startup-config

5. Các lệnh kiểm tra cấu hình
– Lệnh ping có thể dùng với các giao thức khác nhau, thực hiện ở user-mode hay priviledge-mode

RRR#ping ?
WORD Ping destination address or hostname
appletalk Appletalk echo
decnet DECnet echo
ip IP echo
ipx Novell/IPX echo
srb srb echo
<cr>

– Telnet để kiểm tra kết nối IP

RRR#telnet ?
WORD IP address or hostname of a remote system
<cr>

Một cách để kiểm tra hoạt động của cổng giao tiếp của router là dùng lệnh show interface. Lệnh này sẽ hiển thị trạng thái của tất cả các cổng giao tiếp của router.

Router#sh int ?
Ethernet IEEE 802.3
Null Null interface
Serial Serial
accounting Show interface accounting
crb Show interface routing/bridging info
irb Show interface routing/bridging info
<cr>

Có thể chỉ ra cổng giao tiếp để xem thông tin cụ thể về cổng giao tiếp đó.

RRR#sh int e0
Ethernet0 is up, line protocol is up
Hardware is Lance, address is 0010.7b7f.c26c (bia 0010.7b7f.c26c)
Internet address is 172.16.10.1/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:08:23, output 00:08:20, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
...
Một số thông báo sự cố thường gặp đối với cổng giao tiếp serial và cách giải quyết sự cố (trạng thái liên kết xem bằng lệnh show interface serial x trong đó x là số thứ tự của cổng).

Trạng thái của liên kết
Nguyên nhân
Cách khắc phục
Serial x is up, line protocol is up
Đã kết nối được.
Serial x is down, line protocol is down.
Router không nhận được tín hiện carrier detect (CD) do một trong các nguyên nhân sau:
Đường kết nối bị down
Cáp kết nối vào router bị hỏng hay sai.
Phần cứng của router bị hỏng
– Xem lại tài liệu hướng dẫn xem cách kết nối cáp và loại cáp đã sử dụng đúng hai chưa.
– Kết nối vào các cổng khác.

Serial x is
administratively down, line protocol is down. Chưa cho phép router cổng hoạt động. Thực hiện no shutdown trong cấu hình cổng serial ở cả hai phía.
Serial x is up, line protocol is down.
– Cấu hình sai giữa hai router ở hai đầu.
– Remote router không gửi keepalive packet.
– Clock rate chưa được đặt trên Router DCE – Kiểm tra lại cấu hình IP ở hai đầu và phải đảm bảo encapsulation giống nhau.
– Bò lệnh no keepalive ờ hai đầu trong cấu hình cổng serial
– Đặt clock rate cho Router DCE bằng lệnh clock rate xxxxx trong cầu hình cổng serial.

Serial x is up, line protocol is up (looped).
(trạng thái này ít gặp trong lab) Gây nên do trạng thái lặp của đường truyền.
– Dùng lệnh show running–config để xem xét có cổng nào bị cấu hình dưới dạng loop hay không. Nếu có, bỏ trạng thái này đi.
– Reset lại cổng bằng lệnh shutdown, rồi sau đó no shutdown.
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:45 am

Lab 1-4: Cisco Discovery Protocol

Tổng hợp các bài lab ccna(st) 1-4%20Cisco%20Discovery%20Protocol

Mô tả

–Cisco Discovery Protocol (CDP) là giao thức riêng của Cisco dùng để thu thập thông tin về các thiết bị lân cận. Khi sử dụng giao thức CDP, bạn có thể biết được thông tin phần cứng, phần mềm của các thiết bị gần kề. Thông tin này rất hữu ích trong quá trình xử lý sự cố hay kiểm soát các thiết bị trong một hệ thống mạng.

–Bài thực hành này giúp bạn biết được các chức năng và thông số của các lệnh liên quan tới CDP.

+ CDP chỉ cung cấp thông tin về thiết bị nối kết nối trực tiếp, trái với giao thức định tuyến. Giao thức định tuyến cung cấp thông tin cho phép router xác định chặng kế cho các mạng muốn tới.

Thực hiện

Trước tiên, cấu hình các router như sau. Mặc định, các thiết bị Cisco đã có cho phép giao thức CDP. Do đó, khi dùng lệnh show run, thông tin về CDP sẽ không được hiển thị.

RouterA
!
hostname RouterA
!
interface serial0
ip address 172.16.10.1 255.255.255.0
clock rate 64000 ← hoạt động như là DCE cung cấp xung clock
no shut
!
interface ethernet0
ip address 192.168.0.1 255.255.255.0
no shut
!
no ip classless
!
line console 0
line aux 0
line vty 0 4
login
!
end

RouterB
!
hostname RouterB
!
interface serial0
ip address 172.16.10.2 255.255.255.0
no shut
!
no ip classless
!
line console 0
line aux 0
line vty 0 4
login
!
End

1.Để xem thông tin về các thông số thời gian của CDP, dùng lệnh show cdp (hay sh cdp)

Router#sh cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Router#

Dùng lệnh cdp holdtime và cdp timer để đặt lại thời gian gởi và thời gian giữ gói cho router.
– CDP timer là chu kỳ gởi gói CDP tới tới tất cả cổng đang hoạt động.
– CDP holdtime là khoảng thời gian thiết bị giữ gói nhận được từ láng giềng.

RouterA#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#cdp ?
holdtime Specify the holdtime (in sec) to be sent in packets
timer Specify the rate at which CDP packets aresent(in sec)
run
RouterA(config)#cdp timer 90
RouterA(config)#cdp holdtime 240
RouterA(config)#^Z

Bạn có thể tắt hòan tòan giao thức CDP trong thiết bị Cisco với lệnh no cdp run. Để tắt CDP trên một cổng sử dụng câu lệnh no cdp enable trên cổng đó.

2.Lệnh show cdp neighbor (viết tắt sh cdp nei) hiện thông tin về thiết bị nối trực tiếp.

RouterA#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge,
B - Source Route Bridge, S - Switch, H - Host,
I - IGMP, r - Repeater
Device ID Local Interfce Holdtme Capability Platform Port ID
Switch Eth 0 238 T S 1900 2
RouterB Ser 0 138 R 2500 Ser 0
RouterA#

Một lệnh khác cho biết thông tin về các thiết bị láng giềng là show cdp neighbor detail (show cdp nei de), cũng có thể chạy trên router và switch

RouterA#sh cdp neighbor detail
-------------------------
Device ID: 1900Switch
Entry address(es):
IP address: 0.0.0.0
Platform: cisco 1900, Capabilities: Trans-Bridge Switch
Interface: Ethernet0, Port ID (outgoing port): 2
Holdtime : 166 sec
Version :
V9.00
-------------------------
Device ID: 2501B
Entry address(es):
IP address: 172.16.10.2
Platform: cisco 2500, Capabilities: Router
Interface: Serial0, Port ID (outgoing port): Serial0
Holdtime : 154 sec
<...>
RouterA#

Ngoài ra, lệnh show cdp entry * cũng hiển thị thông tin tương tư.̣
Lệnh show cdp traffic hiển thị lưu lượng tại cổng gồm cả số gói CDP gởi nhận và bị lỗi :

RouterA#sh cdp traffic
CDP counters:
Packets output: 13, Input: 8
Hdr syntax: 0, Chksum error: 0, Encaps failed: 0
No memory: 0, Invalid packet: 0, Fragmented: 0
RouterA#

3.Thông tin trạng thái CDP trên port hay cổng hiển thị bằng lệnh show cdp interface (sh cdp int)
Như đã đề cập trước, có thể tắt CDP hoàn toàn trên router dùng lệnh no cdp run. Tuy nhiên, muốn tắt CDP trên từng cổng dùng lệnh no cdp enable. Có thể cho phép CDP trên một port bằng lệnh cdp enable.
Trên router, show cdp interface cho thông tin về từng cổng dùng CDP, gồm cả dạng đóng gói trên đường truyền, timer và holdtime trên mỗi cổng

RouterA#sh cdp interface
Ethernet0 is up, line protocol is up
Encapsulation ARPA
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial0 is administratively down, line protocol is down
Encapsulation HDLC
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial1 is administratively down, line protocol is down
Encapsulation HDLC
Sending CDP packets every 60 seconds
Holdtime is 180 seconds

Tắt CDP trên một cổng

RouterA#config t
Enter configuration commands, one per line. End withCNTL/Z.
RouterA(config)#int s0
RouterA(config-if)#no cdp enable
RouterA(config-if)#^Z

Kiểm tra lại sự thay đổi đó.

RouterA#sh cdp int
Ethernet0 is up, line protocol is up
Encapsulation ARPA
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Serial1 is administratively down, line protocol is down
Encapsulation HDLC
Sending CDP packets every 60 seconds
Holdtime is 180 seconds
Router#

Lưu ý rằng serial 0 không được liệt kê khi thực hiện lệnh trên, nếu dùng lệnh cdp enable trên serial 0, cổng này sẽ hiển thị.
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:46 am

Lab 1-5: Sử dụng Telnet

Tổng hợp các bài lab ccna(st) 1-5%20Telnet

Mô tả

–Telnet là một giao thức đầu cuối ảo (virtual terminal) là một phần của chồng giao thức TCP/IP. Telnet cho phép tạo kết nối với thiết bị từ xa, thu thập thông tin và chạy chương trình.

–Lab này hướng dẫn dùng lệnh telnet và các lệnh liên quan trên router.

+ Virtual terminal (VTY) lines cho phép việc truy cập vào router thông qua các phiên nối kết Telnet. VTY lines không nối trực tiếp vào các cổngs như cách TTY nối vào asynchronous interface mà là các kết nối “ảo” vào router thông qua địa chỉ của ethernet port (cổng ethernet). Router tạo những VTY lines một cách linh động, trong khi đó TTY lines là chỉ nối kết vào những cổng vật lý. Khi người dùng kết nối vào router bằng VTY line, người dùng đó đang kết nối vào một cổng ảo trên cổng.

Thực hiện

Ban đầu cấu hình router như sau

RouterA
!
hostname RouterA
!
interface serial0
ip address 172.16.10.1 255.255.255.0
clock rate 64000 ← hoạt động như là thiết bị DCE cung cấp xung clock
no shut
!
interface ethernet0
ip address 192.168.0.1 255.255.255.0
no shut ← cho phép cổng
!
line console 0
line aux 0
line vty 0 4
login
!
end

RouterB
!
hostname RouterB
!
interface serial0
ip address 172.16.10.2 255.255.255.0
no shut
!
line console 0
line aux 0
line vty 0 4
login
!
end

Đặt địa chỉ IP, mật khẩu dùng để telnet cho Switch

– Với Catalyst 2900

!
hostname Switch
!
enable password cisco
!
interface vlan1
ip address 192.168.0.148 255.255.255.0
!
line vty 0 15
login
password cisco
!
End

Tiến hành các bước sau đây để kiểm tra kết quả:

1.Thử dùng lệnh telnet trên router:

RouterA#telnet 172.16.10.2
Trying 172.16.10.2 ... Open
Password required, but none set
[Connection to 172.16.10.2 closed by foreign host]
RouterA#

+ Đối với Cisco router, bạn không cần phải dùng lệnh telnet mà chỉ cần đánh địa chỉ IP tại dấu nhắc, router sẽ ngầm định rằng bạn muốn telnet vào thiết bị, ví dụ:

RouterA#172.16.10.2
Trying 172.16.10.2 ... Open
Password required, but none set
[Connection to 172.16.10.2 closed by foreign host]
RouterA#

Trong trường hợp trên, mật khẩu chưa được đặt cho đường VTY nên ta không thể telnet vào RouterB được. Đặt mật khẩu cho đường VTY như sau

RouterB#config t
Enter configuration commands, one per line. End with CNTL/Z.
RouterB(config)#line vty 0 4
RouterB(config-line)#login
RouterB(config-line)#mật khẩu Router
RouterB(config-line)#^Z
RouterB#

Thử truy cập bằng cách telnet vào router lần nữa:

RouterA#172.16.10.2
Trying 172.16.10.2 ... Open

User Access Verification

Mật khẩu:
RouterB>

Chú ý rằng mật khẩu VTY là mật khẩu ở user-mode, không phải là enable–mode nên không thể vào enable mode nếu chưa đặt enable password.

RouterB>en
% No password set
RouterB>

2.Telnet vào nhiều thiết bị đồng thời

Bạn có thể giữ kết nối mà trở về router console ban đầu bằng cách nhấn Ctrl+Shift+6 đồng thời, sau đó thả ra và nhấn X.

RouterA#telnet 172.16.10.2
Trying 172.16.10.2 ... Open

User Access Verification

Mật khẩu:
RouterB>[Ctrl+Shift+6, x]
RouterA#

Telnet tiếp tục vào switch

RouterA#telnet 192.168.0.148
Trying 192.168.0.148 ... Open
...
Switch>[Ctrl+Shift+6, x]
RouterA#

3.Kiểm tra các kết nối telnet bằng lệnh show sessions.

RouterA#sh sessions
Conn Host Address Byte Idle Conn Name
1 172.16.10.2 172.16.10.2 0 0 172.16.10.2
* 2 192.168.0.148 192.168.0.148 0 0 192.168.0.148
RouterA#

Dấu Tổng hợp các bài lab ccna(st) 79 nghĩa là session cuối cùng bạn dùng; có thể trở lại session cuối bằng cách nhấn Enter hai lần. Hay muốn tới session bất kỳ bằng cách gõ số của kết nối và nhấn Enter hai lần.

–Kiểm tra Telnet Users

RouterA#sh users
Line User Host(s) Idle Location
* 0 con 0 172.16.10.2 00:07:52
192.168.0.148
Ký hiệu con tượng trưng cho local console.

RouterB>sh users
Line User Host(s) Idle Location
0 con 0 idle 9
* 2 vty 0

Thông tin hiển thị console đang hoạt động và VTY port 2 đang được dùng. Dấu * phiên người dùng hiện tại.
4.Đóng phiên làm việc Telnet
–Có thể đóng phiên làm việc bằng các nhấn exit hay disconnect

RouterA#[Enter] [Enter]
[Resuming connection 2 to 192.168.0.148 ... ]
Switch>exit
[Connection to 192.168.0.148 closed by foreign host]

RouterA#disconnect ? ← tham số theo sau là số thứ tự Conn hiển thị trong lệnh show sessions
<1-2> The number of an active network connection
WORD The name of an active network connection
<cr>
RouterA#disconnect 1
Closing connection to 172.16.10.2 [confirm]
RouterA#

–Để ngắt một kết nối của một user dùng lệnh clear line

RouterB#clear line 2 ← tham số theo sau là số thứ tự line hiển thị trong lệnh show users
[confirm]
[OK]
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:46 am

Lab 1-6: Khôi phục mật khẩu cho Cisco 2600, 3600


Tổng hợp các bài lab ccna(st) 1-6%20Khoi%20phuc%20mat%20khau%202600%203500

Mô tả

–Quá trình khởi động của router đã được định trước. Sau quá trình kiểm tra bật nguồn (POST) và nạp hệ điều hành IOS, router sẽ nạp cấu hình họat động trong NVRAM. Các cấu hình này không chỉ chứa thông tin giao thức định tuyến, địa chỉ mà còn chứa mật khẩu của router.
–Mật khẩu được phục hồi bằng cách bỏ qua nội dung file cấu hình trong NVRAM trong quá trình khởi động. Việc bỏ qua cấu hình được thực hiện bằng cách sửa đổi nội dung thanh ghi cấu hình (configuration register) của router. Lúc này router sẽ không cấu hình chứa mật khẩu cần phục hồi. Khi đã vào được router, người dùng có thể xem mật khẩu trong NVRAM và có thể sử dùng, xoá hay thay đổi chúng. Kỹ thuật hồi phục mật khẩu khác nhau đối với các dòng router, tổng quát cách thực hiện:

1.Nối terminal vào console port.
2.Tắt router và bật lại.
3.Phải ngắt quá trình khởi động của router và đưa nó về monitor mode.
4.Tại monitor mode, cấu hình router sao cho router khởi động mà không đọc nội dung file cấu hình trong NVRAM.
5.Khởi động lại router.
6.Sau khi router khởi động lại, mật khẩu sẽ không còn tác dụng. Vào privileged mode, xem, thay đổi, hay xoá NVRAM mật khẩu.
7.Vào configuration mode và đặt lại thanh ghi để router khởi động từ NVRAM.
8.Nạp lại router. Lúc này mật khẩu đã biết.

+ Khôi phục mật khẩu chỉ có thể thực hiện trên terminal gắn với cổng console của router. Các cách này không thể thực hiện được với cổng aux của router
Cách thực hiện
Phần này hướng dẫn cách khôi phục mật khẩu cho router Cisco 3600 series, Cisco 2600 series.
Trước khi bắt đầu, router phải đặt enable mật khẩu hay login mật khẩu.

Router
!
hostname Cisco3600
!
enable pass cisco ← enable mật khẩu
!
no ip classless
!
line console 0
password cisco ← Login mật khẩu
login
line aux 0
line vty 0 4
login
!
end

1.Tắt router và bật trở lại. Trong quá trình boot, sẽ xuất hiện các dòng sau:

...
Copyright (c) 1994-1996 by cisco system, Inc.
C3600 processor with 16384 Kbytes of main memory
Main memory is configure to 32 bit mode with parity disabled ← Nhấn ngắt (Ctrl+Break) tại đây.

+ Nhấn ngắt ngay khi bật router có thể làm đứng router. Tốt nhất là chờ nhấn ngắt khi router hiện thông báo về kích thước bộ nhớ chính của router.
Bạn cũng có thể nhấn Ctrl+Break trong 15 giây đầu tiên.
Lưu ý rằng đối với các chương trình terminal tổ hợp phím ngắt khác nhau. Phổ biến là Windown HyperTerminal dùng tổ hợp phím Ctrl+Break để ngắt.

2.Lúc này router vào monitor mode, thực hiện lệnh confreg 0x2142

Moniror: command “boot” aborted due to user interrupt

rommon 1 >
rommon 1 > confreg 0x2142

3.Router sẽ nhắc phải reset lại để thay đổi có tác dụng, đánh lệnh reset tại dấu nhắc:

You must reset or power cycle
rommon 2 >
rommon 2 > reset

Router sẽ nạp lại. Lúc này router đã bỏ qua cấu hình trong NVRAM. Khi khởi động xong, nhấn Enter vào user mode và đánh enable để vào privileged mode:

Press Return to get START

Router>
Router>enable
Router#

Dùng lệnh show running–configuration để xem cấu hình hiện tại. Chú ý rằng cấu hình không chứa loại mật khẩu nào. Đây là cấu hình mặc định của router khi bỏ qua file cấu hình trong NVRAM:

Current configuration:
!
version 11.2
...
!
line con 0 ← không có mật khẩu
line aux 0
line vty 0 4
login
!
end

Nếu muốn xem mật khẩu hiện tại và tiếp tục sử dụng nó, dùng lệnh show startup–configuration. Từ cấu hình bạn có thể thấy enable mật khẩu và console mật khẩu là “cisco”. Nếu mật khẩu đã mã hoá bạn sẽ phải thay đổi hay xoá nó.

Router#sh start
Using 355 out of 30712 bytes
!
hostname Cisco3600
!
enable pass cisco ← enable mật khẩu
!
no ip classless
!
line console 0
mật khẩu cisco ← Login mật khẩu
login
line aux 0
line vty 0 4
login
!
end

+ Thay đổi: Để thay đổi mật khẩu hiện thời bạn phải chép cấu hình NVRAM vào running configuration bằng lệnh copy start run.Vào config mode bằng lệnh config term. Đặt lại mật khẩu mới. Nhấn Ctrl–Z để thoát khỏi configuration mode khi hoàn tất. Đánh lệnh write memory hoặc copy run start để lưu cấu hình.
+ Xoá: Có thể xoá mật khẩu bằng lệnh erase start hay write erase

4.Bước cuối cùng thay đổi thanh ghi configuration register để router nạp từ NVRAM.
Xem cấu hình thanh ghi hiện tại:

Router#sh ver
...
Configuration register is 0x2142

Thay đổi thanh ghi

Router#config term
Router(config)#config–register 0x2102
Router(config)#exit

Dùng lệnh show version để xem ảnh hưởng của cài đặt mới.

Router>sh ver
...
Configuration register is 0x2142 (will be 0x2102 at next reload)

Đánh lệnh reload để nạp lại router và làm cho giá trị thanh ghi mới có tác dụng. Bạn không cần phải lưu thay đổi.

Router#reload
System configuration has been modified. Save? [yes/no]: n
Proceed with reload? [confirm]

Router sẽ nạp lại. Nó sẽ lấy cấu hình từ NVRAM, mật khẩu của router bây giờ đã biết và bạn có thể truy cập vào privileged mode của router.

+ Cấu hình bên trong Router gồm những thành phần sau:

RAM/DRAM -- lưu trữ những bảng routing, ARP cache, fast-switching cache, packet buffering (shared RAM), và packet hold queues; RAM cũng cung cấp bộ nhớ tạm thời (running memory) cho file cấu hình của router khi router đang hoạt động; nội dung RAM mất khi tắt nguồn hoặc restart router.

NVRAM -- non-volatile RAM lưu trữ file cấu hình backup/startup của router; nội dung của NVRAM vẫn được giử khi tắt nguồn hoặc restart router.

Flash -- có thể xóa, có thể lập trình lại ROM nơi lưu trữ hệ điều hành và một số mã lệnh (microcode); Bộ nhớ Flash cho phép cập nhập phần mềm mà không cần lấy và thay thế chip xử lý; Nội dung Flash vẫn được giử khi tắt nguồn hoặc restart; Bộ nhớ Flash có thể chứa nhiều versions của phần mềm IOS.

ROM -- chứa chương trình kiểm tra khi bật nguồn router, chương trình bootstrap, và phần mềm hệ điều hành; nâng cấp phần mềm trong ROM đòi hỏi phải lấy và thay thế chip cắm trên CPU.

Interfaces -- Kết nối mạng trên board mạch chủ hoặc trên interface modules riêng biệt, qua đó những packet đi vào và đi ra router.
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:46 am

Lab 1-7: Khôi phục mật khẩu cho Cisco 2500

Tổng hợp các bài lab ccna(st) 1-7%20Khoi%20phuc%20mat%20khau%20cho%202500

Cách thực hiện
–Phần này hướng dẫn cách khôi phục mật khẩu cho router Cisco 2500 series.

Router
!
hostname Cisco2500
!
enable pass cisco ← enable password
!
no ip classless
!
line console 0
password cisco ← Login mật khẩu
login
line aux 0
line vty 0 4
login
!
end

1.Tắt router và bật trở lại. Trong quá trình boot, sẽ xuất hiện các dòng sau:
...
cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-I-L), Version 12.1(3), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Thu 06-Jul-00 07:33 by cmong
Image text-base: 0x0303E710, data-base: 0x00001000
cisco 2511 (68030) processor (revision M) with 14336K/2048K bytes of memory.
Nhấn ngắt (Ctrl+Break) tại đây.

Nhấn ngắt ngay khi bật router có thể làm router ngưng hoạt động . Tốt nhất là chờ nhấn ngắt khi router hiện thông báo về kích thước bộ nhớ chính của router trong quá trình khởi động.
Bạn cũng có thể nhấn Ctrl+Break trong 15 giây đầu tiên.
Lưu ý rằng đối với các chương trình terminal tổ hợp phím ngắt khác nhau. Phổ biến là Windown HyperTerminal dùng tổ hợp phím Ctrl+Break để ngắt.

2.Lúc này router vào monitor mode, thực hiện lệnh o/r 0x42

Abort at ...
>
> o/r 0x42

3.Đánh lệnh i tại dấu nhắc để khởi động lại

>
> i

Router sẽ nạp lại. Lúc này router đã bỏ qua cấu hình trong NVRAM. Khi khởi động xong, nhấn Enter vào user mode và đánh enable để vào privileged mode:

Press Return to get started!

Router>
Router>enable
Router#

Dùng lệnh show running–config để xem cấu hình hiện tại. Chú ý rằng cấu hình không chứa loại mật khẩu nào. Đây là cấu hình lúc router khởi động mà bỏ qua nội dung file cấu hình trong NVRAM:

Current configuration:
!
version 11.2
...
!
line con 0 ← không có mật khẩu
line aux 0
line vty 0 4
login
!
end

Nếu muốn xem mật khẩu hiện tại và tiếp tục sử dụng nó, dùng lệnh show startup–config. Từ cấu hình bạn có thể thấy các lọai mật khẩu được cấu hình trước đó trong router. Nếu mật khẩu đã mã hoá bạn sẽ phải thay đổi hay xoá nó.

Router#sh start
...
!
hostname Cisco3600
!
enable pass cisco ← enable password
!
no ip classless
!
line console 0
password cisco ← Login password
login
line aux 0
line vty 0 4
login
!
end
–Thay đổi: Để thay đổi mật khẩu hiện thời bạn phải chép cấu hình NVRAM vào running configuration bằng lệnh copy start run. Vào config mode bằng lệnh config term. Đặt lại mật khẩu mới. Nhấn Ctrl–Z để thoát khỏi configuration mode khi hoàn tất. Đánh lệnh write memory hoặc copy run start để lưu cấu hình.
–Xoá: Có thể xoá mật khẩu bằng lệnh erase start hay write erase (lúc này đồng thời cũng xóa file cấu hình khởi động). Để không mất file cấu hình, ta có thể dùng thêm từ khóa no trước lệnh đặt mật khẩu, ví dụ: no enable password, no enable secret.

4.Bước cuối cùng, thay đổi thanh ghi để router nạp từ NVRAM.

Xem cấu hình thanh ghi hiện tại:

Router#sh ver
...
Configuration register is 0x42

Thay đổi thanh ghi

Router#config term
Router(config)#config–register 0x2102
Router(config)#exit

Dùng lệnh show version để xem ảnh hưởng của cài đặt mới.

Router>sh ver
...
Configuration register is 0x42 (will be 0x2102 at next reload)

Đánh lệnh reload để nạp lại router và làm cho giá trị thanh ghi mới có tác dụng. Bạn không cần phải lưu thay đổi.

Router#reload
System configuration has been modified. Save? [yes/no]: n
Proceed with reload? [confirm]

Router sẽ nạp lại lấy cấu hình từ NVRAM, mật khẩu của router bây giờ đã biết và bạn có thể truy cập vào privileged mode của router.
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:46 am

Lab 1-8: Nạp IOS Image từ TFTP Server cho router chạy từ Flash

Tổng hợp các bài lab ccna(st) 1-9%201-8%20Nap%20IOS%20tu%20TFTP%20Server%20cho%20Router%20chay%20tu%20RAM%20%28Flash%29
Mô tả
–Bài thực hành này mô tả cách nạp IOS từ router chạy từ flash. Một số router chạy từ flash như Cisco 2500 series hay Cisco 1600 series.
–PC họat động như một TFTP server sẽ nối với router trong cùng mạng LAN. IOS image mới sẽ chứa trong TFTP server và sẽ được truyền qua Cisco router bằng giao thức truyền TFTP. Trong hình vẽ này, PC hoạt động như TFTP server còn router sẽ là TFTP client.

Router chạy từ Flash và router chạy từ RAM
Cisco router có thể thực thi IOS từ RAM hay từ Flash, chạy từ flash chậm hơn.
– Router chạy từ flash là các loại Cisco 2500 series và một số router Cisco 1600 series. Toàn bộ IOS được nạp vào bộ nhớ flash ở dạng không nén. Cisco IOS chạy từ flash. Cập nhật IOS mới trở thành vấn đề: làm sao để nạp vào flash trong khi đang thực thi IOS cũ? Cisco giải quyết điều này bằng một IOS đặc biệt lưu trong ROM. Chương trình giúp đỡ khởi động sẽ nạp lại router để boot từ ROM. Lúc này Flash có thể cập nhật và IOS mới sẽ có thể chạy từ flash.
– Router chạy từ RAM là các đời router Cisco 3600, 4000, 7000, và 7500. Các router này chứa IOS image dạng nén trong flash. Khi khởi động, router sao chép IOS từ flash vào trong RAM và thực thi IOS trên RAM. Các router này có thể cập nhật dễ dàng IOS trong flash bằng cách chép phiên bản mới bằng TFTP.
Thực hiện
–Ban đầu cấu hình của RouterA như sau

RouterA
!
hostname RouterA
!
interface Ethernet0
ip address 10.10.3.253 255.255.255.0 ← Ethernet interface trên cùng mạng với TFTP server
no shut ← cho phép cổng
!
line con 0
line aux 0
line vty 0 4
login
!
end

Dùng lệnh show version để tìm phiên bản của IOS hiện có.

RouterA#show version
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-I-L), Version 12.1(3), RELEASE SOFTWARE (fc1)

Router đang chạy IOS version 12.1(3)

Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Thu 06-Jul-00 07:33 by cmong
Image text-base: 0x0303E710, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE
BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOFTWARE (fc1)

R1 uptime is 1 hour, 22 minutes
System returned to ROM by power-on
System image file is "flash:c2500-i-l.121-3.bin"

IOS được nạp từ flash

cisco 2511 (68030) processor (revision M) with 14336K/2048K bytes of memory. ↑
Router có 16 MB RAM, 14MB dùng cho bộ nhớ xử lý, 2MB dùng
cho bộ nhớ I/O
Processor board ID 07143970, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
16 terminal line(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY) ← router có 8 MB flash
Configuration register is 0x2102

–Xem nội dung bộ nhớ flash dùng lệnh show flash

RouterA#show flash
System flash directory:
File Length Name/status
1 7640212 c2500-i-l.121-3.bin
[7640276 bytes used, 748332 available, 8388608 total]

Để chắc chắn có thể truy cập được TFTP server ở địa chỉ 10.10.3.28, dùng lệnh ping để kiểm tra.

RouterA#ping 10.10.3.28
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.3.28 timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

–Sau khi đã kiểm tra kết nối đến TFTP server như trên, ta bắt đầu nạp IOS mới vào router bằng lệnh copy tftp flash.
–Lưu ý dòng sản phẩm Cisco 2500 là lọai router chạy từ flash.

RouterA#copy tftp flash
**** NOTICE ****
Flash load helper v1.0
This process will accept the copy options and then terminate
the current system image to use the ROM based image for the copy. ← router sẽ nạp IOS image
trong ROM, IOS này sẽ ghi IOS mới vào flash
Routing functionality will not be available during that time.
If you are logged in via telnet, this connection will terminate.
Users with console access can see the results of the copy operation.
---- ******** ----
Proceed? [confirm]
Address or name of remote host [255.255.255.255]? 10.10.3.28 ← địa chỉ TFTP server
Source file name []?c2500-i-l.121-4.bin
Destination file name []?
Accessing tftp://10.10.3.28/c2500-i-l.121-4.bin...
Erase flash: before copying? [confirm] ← xoá nội dung hiện tại của flash

Loading System flash directory:
File Length Name/status
1 7640212 c2500-i-l.121-3.bin
[7640276 bytes used, 748332 available, 8388608 total]
Accessing file 'c2500-i-l.121-4.bin' on 10.10.3.28...
Loading c2500-i-l.121-4.bin from 10.10.3.28 (via Ethernet0):! [OK]

Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erased
Loading c2500-i-l.121-4.bin from 10.10.3.28 (via Ethernet0): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 7640212/8388608 bytes]

Verifying checksum... OK (0x1FC7)
Flash copy took 0:03:47 [hh:mm:ss]
%FLH: Re-booting system after download

Restricted Rights Legend
...
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-I-L), Version 12.1(4), RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Thu 06-Jul-00 07:33 by cmong
Image text-base: 0x0303E710, data-base: 0x00001000

cisco 2511 (68030) processor (revision M) with 14336K/2048K bytes of memory.
Processor board ID 07143970, with hardware revision 00000000
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
16 terminal line(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read ONLY)

Press RETURN to get started!

–Sau khi đã nạp IOS mới dùng lệnh show version để kiểm tra lại router đã chạy IOS mới chưa:

RouterA#show version

–Kiểm tra lại lần nữa bằng show flash.
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:47 am

Lab 1-9: Nạp IOS Image từ TFTP Server cho router chạy từ RAM

Tổng hợp các bài lab ccna(st) 1-9%201-8%20Nap%20IOS%20tu%20TFTP%20Server%20cho%20Router%20chay%20tu%20RAM%20%28Flash%29
Mô tả
–Cấu hình này mô tả cách nạp IOS image từ router chạy từ RAM. Một số dòng sản phẩm router chạy từ RAM là Cisco 2600, Cisco 3600 series, Cisco 4600 series.
–PC chạy TFTP server nối với router trong cùng mạng LAN. IOS image mới sẽ chứa trong PC và sẽ truyền qua Cisco router bằng giao thức truyền TFTP. PC hoạt động như TFTP server, router sẽ là TFTP client.
Thực hiện
–Ban đầu cấu hình của RouterA như sau

RouterA
!
hostname RouterA
!
interface Ethernet0/0
ip address 10.10.3.253 255.255.255.0 ← Ethernet interface trên cùng mạng với TFTP server
!
line con 0
line aux 0
line vty 0 4
login
!
end

–Dùng lệnh show version để tìm phiên bản của IOS hiện có. Lệnh này cung cấp một số thông tin như dung lượng bộ nhớ và image của router

RouterA#show version
Cisco Internetwork Operating System Software
IOS(tm)C2600 Software(C2600-JSX-M),Version 12.1(5)XM,EARLY DEPLOYMENT RELEASE SOFTWARE ↑
Router đang chạy IOS version 11.1 (4)
Image text-base: 0x80008088, data-base: 0x8148BD7C
RouterA uptime is 11 minutes
System restarted by power-on
System image file is "flash: c2600-i-mz.120-3.T3.bin ", booted via flash

IOS được nạp trong flash
cisco 2621 (MPC860) processor (revision 0x102) with 60416K/5120K bytes of memory.

Router có 64MB DRAM, 60MB dùng cho bộ nhớ xử lý, 4MB
dùng cho bộ nhớ I/O
Processor board ID JAB041708RB (3572412720)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
TN3270 Emulation software.
4 Ethernet/IEEE 802.3 interface(s)
2 FastEthernet/IEEE 802.3 interface(s)
2 Serial network interface(s)
32K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read ONLY) ← router có 16 MB flash
Configuration register is 0x2102

–Xem nội dung bộ nhớ flash dùng lệnh show flash

RouterA#show flash
System flash directory:
File Length Name/status
1 3612344 c2600-i-mz.120-3.T3.bin

–Để chắc chắn có thể truy cập được TFTP server ở địa chỉ 10.10.3.28, dùng lệnh ping để kiểm tra.

RouterA#ping 10.10.3.28
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.3.28 timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

–Khi đã kiểm tra kết nối đến TFTP server, ta bắt đầu nạp IOS mới vào router bằng lệnh copy tftp flash. Lưu ý trong bài thực hành này, ta sẽ không xoá file cũ hiện đã có trong flash.

RouterA#copy tftp flash
Address or name of remote host [10.10.3.28]? ← địa chỉ TFTP server
Source file name? c2600-jsx-mz.121-5.xm.bin ← tên của IOS muốn nạp
Destination file name?
Accessing tftp://10.10.3.28/c2600-jsx-mz.121-5.xm.bin
Erase flash device before writing? [confirm]n ← không xoá file hiện tại của flash
Loading c2600-jsx-mz.121-5.xm.bin from 10.10.3.28 (via Ethernet0/0)
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
...
[OK - 3612344/7224320 bytes]
Verifying checksum... OK (0x515A)

–Sau khi quá trình nạp hoàn tất, ta kiểm tra nội dung của bộ nhớ flash bằng lệnh show flash

RouterA#show flash
System flash directory:
File Length Name/status
1 12080536 c2600-jsx-mz.121-5.xm.bin
2 3612344 c2600-i-mz.120-3.T3.bin
[15693008 bytes used, 1084208 available, 16777216 total]
16384K bytes of processor board System flash (Read/Write)

–Lúc này có hai file trong flash. Ta cần khai báo cho router biết dùng file nào trong khi khởi động. Dùng lệnh boot system flash trong configuration mode

RouterA#conf term
RouterA(config)#boot system flash c2600-jsx-mz.121-5.xm.bin
RouterA(config)#exit

–Kiểm tra lại bằng show run để chắc chắn câu lệnh đánh đúng
–Lưu cấu hình dùng lệnh write memory (hay copy run start) và sau đó nạp lại

RouterA#write mem
Building configuration ...
[OK]
RouterA#reload
Proceed with reload? [confirm]

–Sau khi đã nạp IOS mới dùng lệnh show version để kiểm tra lại router đã chạy IOS mới hay chưa:

RouterA#show version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-JSX-M), Version 12.1(5)XM,
...
System file image “flash: c2600-jsx-mz.121-5.xm.bin“

Nếu muốn nạp IOS mới mà không giữ phiên bản cũ, cũng dùng lệnh copy tftp flash và cho phép xoá flash trước khi ghi.

RouterA#copy tftp flash
System flash directory:
Address or name of remote host [10.10.3.28]? ← địa chỉ TFTP server
Source file name? ← tên của IOS muốn nạp
Destination file name?
Accessing file tftp://...
Erase flash device before writing? [confirm] ← Nhấn Enter tại đây để cho phép xóa flash trước khi ghi file mới
Erasing the flash filesystem will remove all files! Continue? [confirm]
Erasing device ...
eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ee ...erased
Erase of flash: complete
Copy ...
as ...? [yes/no]y
Loading
!!!!!!!!!!!!!!!!!!!!
[OK - 12080536/24160256 bytes]
Verifying checksum... OK (0xECAC)
12080536 bytes copied in 100.524 secs (120805 bytes/sec)

Sau khi nạp xong hệ điều hành cho router, nên kiểm tra lại tình trạng các file hiện có trong flash bằng show flash hoặc dir flash:
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Admin on Mon Oct 25, 2010 10:47 am

Lab 1-10: Nạp IOS image cho router bằng Xmodem


Tổng hợp các bài lab ccna(st) 1-2%201-3%20Dat%20mat%20khau%20truy%20cap%20%28Cac%20lenh%20co%20ban%29

Mô tả

Bài thực hành này mô tả cách nạp IOS bằng giao thức Xmodem/Ymodem cho dòng router 2600, 3600 khi router gặp sự cố và không thể nạp IOS theo cách dùng TFTP server. IOS image được đặt trên PC, dùng giao thức truyền Xmodem hay Ymodem để truyền file IOS qua router qua cổng console. Trong thực tế ta có thể gặp tình huống này khi router bị mất IOS.
- Có thể truyền IOS image từ máy tính ở xa bằng cách nối modem với cổng console của router nối qua mạng điện thoại thông thường (PSTN). Máy tính từ xa cũng nối modem với mạng điện thoại , từ máy tính này quay số và kết nối với router.
- Để truyền IOS image từ một máy tính cục bộ, kết nối cổng console router với cổng serial của máy tính, dùng cáp null-modem (tức cáp rollover). Tốc độ cổng console cấu hình trên router phải phù hợp với tốc độ cổng serial (COM1 hoặc COM2) của PC.

Cấu hình dưới đây mô tả cách nạp IOS cho router qua cổng console.

Các câu lệnh được thực hiện trên nhóm router 2600, 3600 sẽ khác với router 2500 nhưng đều tuân theo các bước cơ bản sau:

1.Nối router với máy tính qua cổng console, khởi động router.
2.Đặt tốc độ lại cho cổng console là 115200 bps.
3.Khởi động lại router .
4.Chỉnh lại thông số chương trình HyperTermial cho phù hợp.
5.Dùng lệnh xmodem để bắt đầu quá trình nhận file trên router.
6.Khởi động quá trình truyền file bằng xmodem từ chương trình HyperTermial.
7.Chờ tới khi quá trình truyền hoàn tất, router khởi động từ IOS mới.
8.Đặt lại tốc độ 9600 bps cho cổng console (tức đặt lại giá trị mặc định cho thanh ghi).

Thực hiện

1. Một router khi không có IOS image trong flash lúc khởi động sẽ vào tự động vào chế độ ROM monitor. Dấu nhắc ROM monitor khác nhau ở các nhóm router 2600, 3600 và router 2500.
Router 2600
rommon 1>
Đối với router 2500, dấu nhắc sẽ có dạng:
>

Đặt lại tốc độ cổng console là 115200 bps và khởi động lại router

Đối với Router 2600
Dùng lệnh confreg để đặt lại giá trị thanh ghi cấu hình, có thể thực hiện bằng hai cách:

rommon 2 > confreg 0x3822
You must reset or power cycle
rommon 3 > reset

hoặc chỉ đánh lệnh confreg sau đó trả lời các câu hỏi theo sau:

rommon 2 > confreg
Configuration Summary
enabled are:
load rom after netboot fails
console baud: 9600
boot: image specified by the boot system commands
or default to: cisco2-C2600
do you wish to change the configuration? y/n [n]: y
enable "diagnostic mode"? y/n [n]: n
enable "use net in IP bcast address"? y/n [n]: n
disable "load rom after netboot fails"? y/n [n]: n
enable "use all zero broadcast"? y/n [n]: n
enable "break/abort has effect"? y/n [n]: y
enable "ignore system config info"? y/n [n]: n
change console baud rate? y/n [n]: y
enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400
4 = 19200, 5 = 38400, 6 = 57600, 7 = 115200 [0]: 7
change the boot characteristics? y/n [n]: n
Configuration Summary
enabled are:
load rom after netboot fails
break/abort has effect
console baud: 115200
boot: image specified by the boot system commands
or default to: cisco2-C2600
do you wish to change the configuration? y/n [n]: n
You must reset or power cycle for new config to take effect
rommon 3 > reset

Đối vói router 2500

>o/r 0x3822  đặt lại giá trị thanh ghi
>i  khởi động lại router

2. Sau khi khởi động lại router, tốc độ bit đã thay đổi, phải thiết lập kết nối mới (File – New Connection ...), chỉnh lại thông số HyperTermial cho phù hợp với tốc độ console mới là 115200 baud. Với tốc độ này sẽ giảm thời gian truyền IOS image.

"_nR!1bŒ›R  ký tự lạ xuất hiện do không phù hợp tốc độ phải chỉnh lại thông số COM1 như sau:

Tổng hợp các bài lab ccna(st) Image054

3. Thực hiện lệnh xmodem với thông số theo sau là file IOS image muốn nhận.

rommon 1 > xmodem c2600-io3-mz.121-5.T
Do not start the sending program yet...
File size Checksum File name
4032136 bytes (0x3d8688) 0xaca4 2600.12.0.7.bin
WARNING: All existing data in bootflash will be lost!
Invoke this application only for disaster recovery.
Do you wish to continue? y/n [n]: y
Ready to receive file c2600- io3-mz.121-5.T ...

4. Khi màn hình hiện thông báo đã sẵn sàng nhận file, right click trên màn hình chọn Send File ... (hoặc chọn từ menu Transfer / Send File ...)
Chọn Filename thích hợp và Protocol là Xmodem; nhấn Send
Thực hiện chỉnh các thông số như các hộp thoại sau:

Tổng hợp các bài lab ccna(st) Image055

Giao thức gởi file Xmodem

Tổng hợp các bài lab ccna(st) Image058
Tổng hợp các bài lab ccna(st) Image060


(tại HyperTeminal)
Erasing flash at 0x607c0000
program flash location 0x60510000
Download Complete!  chờ tới khi thông báo hoàn tất quá trình kiểm tra, router tự khởi động lại
program load complete, entry point: 0x80008000, size: 0x517174
5. Router đã khởi động lại, đặt giá trị thanh ghi về mặc định

...
Would you like to enter the initial configuration dialog? [yes/no]: No

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#config-register 0x2102  Thay đổi giá trị thanh ghi về mặc định
Router(config)#exit
6. Kiểm tra lại file mới đã được nạp

Router#show flash
System flash directory:
File Length Name/status
1 5337744 c2600-io3-mz.121-5.T  file mới đã lưu trong flash
[5337808 bytes used, 3050800 available, 8388608 total]
8192K bytes of processor board System flash (Read/Write)

Router#show version
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-IO3-M), Version 12.1(5)T, RELEASE SOFTWARE(fc1)
...
System image file is "flash:2600.12.0.7.bin"
Basic Rate ISDN software, Version 1.1.
1 FastEthernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
1 ISDN Basic Rate interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)
Configuration register is 0x3822 (will be 0x2102 at next reload)

Router#copy run start
Admin
Admin
Ban Quản Trị
Ban Quản Trị

Dog
Tổng số bài gửi : 993
Số Điễm : 2909
Join date : 18/08/2009
Age : 36
Đến từ : Quảng Ngãi

Xem lý lịch thành viên http://dailong.forum-viet.net

Về Đầu Trang Go down

Tổng hợp các bài lab ccna(st) Empty Re: Tổng hợp các bài lab ccna(st)

Bài gửi by Sponsored content


Sponsored content


Về Đầu Trang Go down

Về Đầu Trang


 
Permissions in this forum:
Bạn không có quyền trả lời bài viết